Alexor app from Google Play

I am trying to connect the app to my self hosted Axelor instance

I am currently trialing the software with the intention of implementing it within the business.

Since it is currently being trialled, there is no domain name associated, only and ip:port

Also, I am hosting the software in a docker container

The problem I am having is that when I enter the url as http://myip:port/ and ender my user details, the spinner comes up and spins for a minute or 2 and then I get the error invalid Axelor URL`

Does the app work with Axelor that is being self-hosted via Docker?

How do I sort the problem?


I thank I have managed to fix the above

Now when I try to login, I get the error invalid credentials but I am using the username and password I created

1 J'aime

Hello
I tested Axelor App for Android (not great).
You need to enable each user to be allowed to use APP (API)
Also I would recommend to buy a cheap domain and use it instead IP and PORT

@fabiobottan

Excuse my naivety, I have looked through axelor and cannot see where to enable app access, is there documentation on this?
Im actually struggling to get any apps to show on a users dashboard at the minute as well

I am using the IP:port for testing, I will be moving it over to my new server with a subdomian.domain.co.uk

ip port can work too, you need to give URL, also needs to install axelor mobile module and allow users modules

1 J'aime

@siddique the Mobile module has been added but I still cant find where to allow users access?

1 J'aime

See this screenshot.
User confirguration

@fabiobottan This is where I have been looking

The chosen options in the pic above are the only options I have available

image

As you can see, the module has been installed.

I have also tried restarting the container with no joy

@fabiobottan I have also added all the permissions in the field below

Still no joy!

Did you enable all in the module?
Click on « Configure » button

@fabiobottan

That is the current set up

Any error from App?

@fabiobottan Only, invalid credentials

1 J'aime

My only difference from you I use a domain only.