Tomcat not starting up after installation

Hi everyone,

I’ve been trying for the last couple of hours to install from the sources for linux, I followed the install documentation step by step, except for the postgres part since I’m using AWS RDS, the built succeed and everything was going smoothly until the last command where I have to start Tomcat:

$ sudo su -c « JAVA_OPTS=-Daxelor.config=/opt/tomcat/ /opt/tomcat/bin/ run » tomcat

The documentation says:

If everything is fine, you can see application log on terminal. After a while, you may see something like this:

Ready to serve...

But I get no message at all and no service is listening on the 8080 port (Unable to connect to the website).
I tried creating a service file for Tomcat and surprisingly It worked and the webserver is up, except that It’s the default tomcat page, not Axelor, so I added this line to the service file:


but nothing changed.

Any ideas?

Thank you

The best way to see what is happening is to check the log. Please check this file

The following command:

$ sudo su -c « JAVA_OPTS=-Daxelor.config=/opt/tomcat/ /opt/tomcat/bin/ run » tomcat

writes nothing to the catalina.out, the commands:

sudo service tomcat stop
sudo service tomcat start

do write the normal info about stopping/starting the server instance


I edited the tomcat-users.xml & context.xml to be able to get to the manager interface, but the server did not start, I noticed this error:

23-May-2020 15:07:55.037 SEVERE [Catalina-startStop-1] org.apache.catalina.startup.HostConfig.beforeStart Unable to create directory for deployment: [/opt/tomcat/conf/Catalina/localhost]

So after creating the Catalina folder inside the conf & give It permissions, I am able to get to the manager, but there were no mention of the ROOT.war file that I copier earlier, I do not want to use the « Deploy » section since that would be taking It a bit too far from the original install documentation.

Update 2:
I am not sure at what point this happened, but 742 tables were created in my database.


Check this updated Ubuntu 18 installation steps