Trouble with SSL / https

Hello, I need your help with my axelor installation, please.

☞ SYNOLOGY NAS (latest version)
☞ nginx / Apache webserver (version 1.16.1 / 2.4)
☞ axelor Docker image (latest version)

Initial test
When I first tried the application via http it worked perfectly fine.

1st Problem: https
Of course I want to change to https because of security reasons.
So I generated an openssl certificate and run axelor via docker from my terminal:
sudo docker run -it -v PATH/TO/CERTS:/etc/nginx/certs -p MYPORT:443 axelor/aio-erp

After opening https://SYNOLOGYNASIP:MYPORT I receive the login page (https://SYNOLOGYNASIP:MYPORT/login.jsp). But no matter what after entering my username and password I return to the blank login form as if nothing happened but a reload.

What do I have to do to find out where my mistake is? Logging?
Does anyone know how to solve this? :sweat_smile:

2nd problem: Startup speed
By the way: Starting up axelor via Terminal takes ages – like half an hour minimum. Is this behavior normal?

Thank you for your help! :grin:

Could there be a similar problem like [SOLVED] Axelor behind nginx as a reverse proxy?

But I tried both: nginx and Apache as backend server.

if you talking about gradlew run it’s normal but depends on machine spec too

first time it creates database tables and import data

we are running fine behind nginx in kubernetes ingress

docker logs can help

1 « J'aime »

Thank you for your fast response.
I am not sure what a gradlew run is, but it is good to know that initial startups take that much time.

The 1st problem is most important to me. Is there something I should search for (concerning docker logs) in particular?

just run docker without -d option and share logs might be i can help

1 « J'aime »

That is very kind. But I am good … now.

Unfortunately it was my own stupidity. Despite what I wrote in my first post I had a startup script for Axelor which was missing the colon after the local certificate path.


docker run -it -v PATH/TO/CERTS/etc/nginx/certs -p MYPORT:443 axelor/aio-erp


docker run -it -v PATH/TO/CERTS:/etc/nginx/certs -p MYPORT:443 axelor/aio-erp

Thank you for your time.

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.