Can't deploy from the source

Hi Everyone,

I’m trying to install Axelor open-suite-webapp on my Ubuntu 23.04.
I followed both youtube guides (environement setup & deployment) and I have a lot of errors when it comes to the « gradlew clean build » step.

Here are my components :
Postgresql => 14
**OpenJdk => 11 **
Tomcat => 9.0.85
Axelor => 7.2.6

When I run the gradlew I have a lot of warning & notes :
Execution optimizations have been disabled for task ‹ :modules:axelor-bank-payment:compileJava ›
/sources/open-suite-webapp/modules/axelor-open-suite/axelor-talent/src/main/java/com/axelor/apps/talent/web/ uses unchecked or unsafe operations.

And the operation is always a FAILURE :
FAILURE: Build failed with an exception.

  • What went wrong:
    Gradle build daemon disappeared unexpectedly (it may have been killed or may have crashed)

It seems like it’s an Out Of Memory issue so I tried to upgrade the machine memory and I also tried to run the « ./gradlew clean build -Dorg.gradle.jvmargs=-Xmx4096M » command based on what I saw on forums.

This does’t change anything and I was only able to perform a successful build when I removed the « clean » from the command but after that I copied the war file into the tomcat folder and tomcat was also generating a lot of errors.

Here a screenshots of the errors (too much logs so it doesn’t take every errors…) :

If anyone can help on this would be greatly appreciated !

Hi @Esthar please share a full screenshot for errors during build, it may helps.

Hey, thanks for your answer.
I did it by editing the original post

@Esthar ok, i can see the screenshots.
So one question:

Did you modified the following files in order to remove references to CI?

« AXELOR_PAGTH\modules\axelor-open-suite\axelor-project\src\main\task-editor »?
« AXELOR_PATH\modules\axelor-open-suite\axelor-human-resource\src\main\axelor-react-timesheet »?

As mentionned I just followed the youtube guide, and there is no mention of modifying these files in it, so no I didn’t touch anything about these files

@Esthar OK, so you MUST modify theses files, as per following:


« scripts »: {
« start »: « node scripts/start.js »,
**« build »: « set 'CI=false' && node scripts/build.js »,**
« test »: « node scripts/test.js --env=jsdom »


« scripts »: {
« start »: « react-scripts start »,
**« build »: « set 'CI=false' && set 'GENERATE_SOURCEMAP=false' && react-scripts build »,**
« test »: « react-scripts test »,
« eject »: « react-scripts eject »

Please give particular attention du simple quotes (') and double quotes (")

Thanks for your answer.
I made the change accordingly to what you mentionned but I still have critical errors for the build step :

What command do you use to build right now?

I tried different commands, all result in an failure :
./gradlew clean build
./gradlew clean build -Dorg.gradle.jvmargs=-Xmx4096M
./gradlew clean build -Dorg.gradle.jvmargs=-Xmx2096M

So, the first command (./gradlew clean build) is the right one.
Stick with it !

However, the issue that you are facing, seems to be known and may be related to Gradle lack of memory (Gradle build daemon disappeared unexpectedly (it may have been killed or may have crashed) while building Android project on Jenkins - Stack Overflow).

So instead of trying to upgrade gradle memory in build command, you should try like this:
Add :


in ~/.gradle/


This doesn’t change anything I still have errors when building … :

I did a complete reinstall with postgresql 12 since I red some stuff about version issues but this doesn’t change anything either.

This really seems to be related to Gradle somehow, you may try to get logs from gradle separaltely to see what is going wrong.

./gradlew clean build > gradle_common_logs.txt 2> gradle_error_logs.txt

Since you will redirect Gradle logs, you may not see anything happen on screen while using the specified command.
You have to wait anyway.

The logs files will appear in the « parent » repository folder.
2024-01-17 14_21_43-Window

Here screenshots of the logs :

@Esthar Maybe this:


Fix source:


Thanks again for your answer.
This doesn’t fix the gradlew clean build step…
I just followed the guide, I don’t understand why I need to modify some files which are not specified and why I’m encountering this type of issue.
I don’t understand these error/warning messages everywhere since I just followed the guide …

Well, it is true that the guide should be followed as it is, but it is not up to date…
And sometimes, as you are not using the same build environnement as Axelor Team, you may face issue.

I also faced tons of issue for my first builds.
I am using Windows in order to build from sources.

And almost all the issues that i faced, were not documented (such as Windows Defender…).

Right now, i am lack of solutions for your issue, however i may advise you to do some cross tests, suchs as :

  • Try on another ubuntu version, eg: 22.04 (which, by the way is the most stable as it’s LTS).
  • Try on another linux distro : (Debian…)
  • Try on Windows.

@Esthar did you managed to build ?

He didn’t manage to build but he manage do deploy from the ready github’s WAR file v7.2.6

Hey, nope as fecarian said we did it without building