Can't start Axelor from all-in-one bundle

Hello,

I wanted to test Axelor using all-in-one bundle, but I’m unable to do so. Actually, I think I encountered two separate problems. I use Windows 10.

First, I tried to run the bundle from the exe file. Unfortunately, nothing’s happening. No error, no stacktrace, no exception thrown – nothing. Running the executable as administrator didn’t help. I found topic on the forum that describes a similar issue – link. It wasn’t much help, though.

So, I started tinkering. Found out that I can launch Axelor by starting ./lib/axelor-launcher.jar . To keep data in var directory, I start launcher from root directory by java -jar lib/axelor-launcher.jar . (I tried to run it directly from the lib directory, too; the behaviour described later seems to be not affected by that at all).

The first configuration steps seem to be completed successfully, but execution stops with The JRE_HOME environment variable is not defined correctly message. The full log from the launcher window you can read on pastebin.

Most likely it’s Tomcat server failing to start. When I try to start Tomcat manually ( opt\tomcat\bin\startup.bat ), the same message appears.

After some digging, I set environmental variables as described at stackoverflow. Tried to set them permanently, tried to set them temporarily via the batch file. The message about JRE_HOME set incorrectly persists.

  • set JAVA_HOME E:\programming\java\jdk\jdk_8_hotspot\bin
  • set JRE_HOME E:\programming\java\jre\jre_8_hotspot\bin
  • set CATALINA_HOME E:\tools\erp\axelor\opt\tomcat
  • set CLASSPATH %JAVA_HOME%;%JRE_HOME%;%CATALINA_HOME%\lib

Java is set in path, too.

Tried the above with both Java 8 and Java 11.

I’m not sure what else could I try to run Axelor. Would appreciate some help here.

Best regards
Pors

edit: grammar

It’s solved.

Looks like the default Tomcat configuration can’t find jdk in the opt folder. Looks like it also overwrites environmental variables, so tinkering with system / user JAVA_HOME and JRE_HOME had no effect.

I manually added JAVA_HOME and JRE_HOME to the catalina.bat file of Tomcat and everything seems to work well since then.