Deploying to Kubernetes

We are trying to deploy Axelor to Kubernetes. Has anyone done a Helm Chart for it?

If you have a solid Helm chart, that would really be appreciated.

Failing that, a working docker-compose.yaml file, containing all of the elements of the complete all-in-one deployment, including database connectivity and all modules would enable us to create a helm chart ourselves.

Thank you for your kind assistance.

1 « J'aime »

I know @siddique did something with Kubernetes

1 « J'aime »

yes, we deployed it on kubernetes, you can use helm chart related to tomcat, rest save app.prop in configmap

3 « J'aime »

Thank you for your quick response. That sounds like a good approach.

Would it be possible for you to push your helm chart and app.prop to the axelor docker repo? That would be excellent!

We are keen to use Axelor in our Kubernetes production cluster.

i am not allowed to do that

Allowed by whom, sorry? You are not allowed to push to the repo? You are not allowed by your company? Axelor does not permit it? My apologies, I don’t understand.

Is there someone who can help us? Is there any way for us to get a working helm chart for Axelor?

Failing all of the above, as a last resort, perhaps you could write an article containing instructions for how to do this?

Any help you can provide would be very much appreciated.

I will write an article, what issue you are facing while using Tomcat helm

Hi, and thank you again for getting back to us. Writing an article would be very helpful.

You asked what issues we are facing; I have been told that the image we have been testing is 3 years old.

Would it be possible for someone to update that image to the latest build? We are reluctant to recommend Axelor until we can test the latest release.

Updating the aio-erp image would be a huge help.

Thank you!

I have written one with GitHub actions, we can adopt it for k8s, we just don’t need to ssh

you can see how I avoiding the base axelor image:)

Thank you Siddique. I will need to get one of my team to look at your article and try it out - I like the way you are using Git, that’s very interesting. Just as an aside, have you tested it recently? Are you certain it will still build?

Update: One of my team has been able to run the aio-erp image in docker and deploy that to K8s in the usual manner. However, as I am sure you are aware, the aio-erp image is 3 years old.

Here is the problem; we have tried to rebuild the aio-erp image ourselves, by following the instructions exactly as written at

This fails. I won’t include the failures here, because it is very easy to see how it fails by simply trying it for yourself - it takes about 5 minutes. The aio-base and aio-builder both fail, and no images are generated. This is unexpected behavior.

Can someone please let me know if this axelor-docker build failure issue can/will be fixed? This is actually becoming an urgent issue for us, as we need to make some major decisions around Axelor in the next few days. Should we cross Axelor off of our list of ERP solutions? We like Axelor very much, but if it has gone out of maintenance, which is unfortunately what this looks like, then that is important for us to know.

Thank you all for your hard work. Please let me know as soon as possible.

Kind regards,

I will not let the Axelor down just for this reason, see docker repo is not maintained, but you can see we are using it, and how we are using is the industry best practice, so there are approaches to do things and we adopt the easiest one as being lazy naturally.

And to evaluate something directly k8s is not best practice, you can get any instance up with plain java 8 installed on that system.

I am hopeful you will chose Axelor as your next ERP, nothing is perfect or ideal, we have to mold it to our needs.

Hi Siddique and Axelor Team,
Siddique, again, thank you for your response. Happily, K8S is no longer the issue. The issue is that the axelor-docker project cannot be built into a new aio-erp image to replace the 3 year old one. If that can be done, all our problems are solved.

The project code looks reasonable - it appears to only fail because it is using old, out of date libraries. This should be an easy fix for someone who is familiar with the code, and able to perform tests.

Is it possible for someone to upgrade the axelor-docker files, so that the images can be built, as described in the instructions?

Please let me know if this can be done.

Kind regards,

this is doable, I have used it with few adjustments, I can write the article and create PR for this

1 « J'aime »

Thank you Siddique, that’s terrific! I am really excited about using that new aio-erp image :slight_smile:

I have created the fork, removed and update packages which were not required or old

3 « J'aime »

Hi Siddique, thank you so much! This is great work!

I built it, and it runs. The only issue I encountered was in

There is a double ‹ && › in lines 15-16. Once I took out the extra &&, it built cleanly. You might want to make that change in your fork.

I ran aio-erp in a VM, and it worked as expected. Very nice! I am very glad to see this working with fresh code :smiley:

I had a quick look at the application, and it looks very nice. I will need to add volumes, to test it out further, but it is good to see. Would you be able to push your changes to the main repository, and regenerate the aio-erp image in docker-hub so that our helm chart can pull down from the official source? That would be outstanding.

Well-done Siddique, and thank you again! We will definitely be progressing our evaluation of Axelor, thanks to your excellent assistance.

Kind regards,

1 « J'aime »

Fixed, I have added this to docker hub you can use it

docker pull siddiqueahmad/axelor-docker:axelor-webapp-aop-54

Thank you!

Oh, just to let you know, this non-breaking warning came up during the build process;

« Node.js 10.x is no longer actively supported! »

Other than that, I don’t recall seeing any other major warnings. All good :slight_smile:

When will your changes be pushed up to and to Docker Hub ?

Do you have permission to commit code and images there?

I intentionally not changed the nodejs version, just to not break more dependencies, default version is nodejs 10.

i am not their team member, that’s why I pushed to own docker account.

2 « J'aime »