Enter time spent on tasks - conflict between hours and days

I have been using Axelor for a while and on the whole I am now getting to grips with it and using with my team.

However one issue I cannot work out. When I enter time on a task, what I am assuming to be in hours (as it states in the manual) is actually recording it as a fraction of days.

For example, if I enter 1.5 - I think this is 1.5 hours, but actually it is 1.5 days and this is shown on the Timesheets as 11.25 hours. Do we really have to work to 1 hour as 1/7.5 (0.13333) to enter time or is there something I have missed?


In timesheet app configuration you should set hours instead day? Did you check it?
Seems a conflict with that.

Hi Fabio,
There doesn’t appear to be an entry that allows that to be configured.

Hello @simondawson

Sorry, it’s App Base configuration

1 « J'aime »

Thanks Fabio for responding so quickly.

Ok, I’ve had a look at that and it was set to hours. So I thought that maybe a reset was needed so I then set it to days, added a timesheet entry, which was converted into 7.5hrs; I then set it back to hours and tried again - converted to 7.5 hours again; then tried it as minutes and it did the same. Everything I set it to, results in the recrded data being in days.

:thinking: :thinking:

I have solved this…but not through the UI of Axelor. Instead I have edited the Postgres database directly for the timesheets directly (hr_timesheet table) and adjusted the time_logging_preference_select column to show hours.

It now works. I realise this is not, probably - actually certainly, the best solution, but it is a work around for others experiencing the same issue.

1 « J'aime »

Good idea.
Actually for employee configuration each employees at timesheet tab configuration you can choose hours/days

Ce sujet a été automatiquement fermé après 30 jours. Aucune réponse n’est permise dorénavant.