Error Axelor Install adk

I am having an error while performing gradlew installDist.

First I made the git clone: git clone
He did the procedure without problems.

After the procedure, I gave the command: gradlew installDist.

Displays the following error in the console

FAILURE: Build failed with an exception.

What went wrong:
Could not resolve all dependencies for configuration ‘:runtime’.

Could not resolve com.axelor:axelor-cglib:3.1.
Required by:
com.axelor:buildSrc:4.1.2 > com.axelor:axelor-gradle:4.1.2 > com.axelor:axelor-common:4.1.2
Could not resolve com.axelor:axelor-cglib:3.1.
Could not get resource ‘’.
Could not GET ‘’.
peer not authenticated



Recently we migrated our nexus repository server on secure https protocol. The old http urls are redirected to https.

Can you open the url in browser to see if url is redirected ?



I had the same problem, but it was because I installed java8 on my osx machine. 

I kept the java7 jdk but it seems osx is having problems to link to the proper library.
So I just did a test, git clone the axelor repository on a ubuntu with java 7 jdk and it
worked perfectly, thus I am assuming it was because of a java jdk conflict.

Hi @fuhr

As @marioestradarosa point out, make sure you have java8 installed. You can check it by running java -version :

# java -version
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

Then installDist command should work.


We had a similar problem on Centos 7 with
[root@hoteldev64demolance ~]# java -version
java version “1.8.0_51”
Java™ SE Runtime Environment (build 1.8.0_51-b16)
Java HotSpot™ 64-Bit Server VM (build 25.51-b03, mixed mode).

What I had to do was temporarily "export JAVA_HOME==/usr/lib/jvm/java-1.7.0-openjdk-
Run “axelor run” and let it download the files from the Axelor repository using http.
After that the build failed once more so I switched back to the 1.8 jdk and the Axelor demo build completed.

Update- We tried it on another similarly configured Centos 7 VM and the same java version “1.8.0_51” did not fail. Therefore, our results are inconclusive. Still, one way or another we have been able to get past the problem.

I check on a fresh Ubuntu 16.04.2 LTS system. I can reproduce the same error if java8 is not used.
Note that JAVA_HOME is an environment variable that contains the directory where Java is installed and java -version is a command that shows which version of Java is installed (the one that’s used by default in case a few versions are installed).
Our gradlew script determine the java command to use as following : First check for a valid JAVA_HOME and use it then use java found in path (JDK that the java command comes from).

I my case it is all consistently jdk1.8. At any rate, since temporarily switching to jdk1.7 get’s past the problem I thought I would share that observation.

[root@hoteldev64demolance ~]# echo $JAVA_HOME
[root@hoteldev64demolance ~]# which java
[root@hoteldev64demolance ~]#
[root@hoteldev64demolance ~]# java -version
java version “1.8.0_51”
Java™ SE Runtime Environment (build 1.8.0_51-b16)
Java HotSpot™ 64-Bit Server VM (build 25.51-b03, mixed mode)

1 « J'aime »