Getting error while building mobile app

Hi Team,

I am getting below error while building mobile app. Kindly help me to fix this issue.

lerna info version 2.5.1
lerna info versioning independent
lerna info scope ‹ @axelor/
lerna ERR! EPACKAGES Errored while collecting packages and package graph
lerna ERR! Error: No packages found that match scope ‹  ›@axelor/
 ›’
lerna ERR! at Function.filterPackages (D:\axelor\node_modules\lerna\lib\PackageUtilities.js:217:17)
lerna ERR! at RunCommand.runPreparations (D:\axelor\node_modules\lerna\lib\Command.js:326:60)
lerna ERR! at D:\axelor\node_modules\lerna\lib\Command.js:225:18
lerna ERR! at new Promise ()
lerna ERR! at RunCommand.run (D:\axelor\node_modules\lerna\lib\Command.js:212:14)
lerna ERR! at Object.handler (D:\axelor\node_modules\lerna\lib\commands\RunCommand.js:45:88)
lerna ERR! at Object.self.runCommand (D:\axelor\node_modules\yargs\lib\command.js:233:22)
lerna ERR! at Object.Yargs.self._parseArgs (D:\axelor\node_modules\yargs\yargs.js:990:30)
lerna ERR! at Object.Yargs.self.parse (D:\axelor\node_modules\yargs\yargs.js:532:23)
(node:18588) UnhandledPromiseRejectionWarning: Error: No packages found that match scope ‹  ›@axelor/*’’
at Function.filterPackages (D:\axelor\node_modules\lerna\lib\PackageUtilities.js:217:17)
at RunCommand.runPreparations (D:\axelor\node_modules\lerna\lib\Command.js:326:60)
at D:\axelor\node_modules\lerna\lib\Command.js:225:18
at new Promise ()
at RunCommand.run (D:\axelor\node_modules\lerna\lib\Command.js:212:14)
at Object.handler (D:\axelor\node_modules\lerna\lib\commands\RunCommand.js:45:88)
at Object.self.runCommand (D:\axelor\node_modules\yargs\lib\command.js:233:22)
at Object.Yargs.self._parseArgs (D:\axelor\node_modules\yargs\yargs.js:990:30)
at Object.Yargs.self.parse (D:\axelor\node_modules\yargs\yargs.js:532:23)
at Object. (D:\axelor\node_modules\lerna\bin\lerna.js:4:25)
(Use node --trace-warnings ... to show where the warning was created)
(node:18588) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag --unhandled-rejections=strict (see https://nodejs.org/api/cli.html#cli_unhandled_rejections_mode). (rejection id: 2)
(node:18588) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! @ build: lerna run prepublish --scope '@axelor/*' && lerna bootstrap
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the @ build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

Hi Team,

Kindly share the update on above query.

Thanks

Hello , how can you have axelor mobile source ?
Regards

HEllo , how can i get Mobile Source ?
REgards

The mobile sources are available in github repository.

Kindly help anyone to resolve this build issue

Thanks , great news , i try to compile .
Regards

Hi Durtaut,

If you are able to compile and build that, please help me to build the same

Hi Team,

Kindly provide the update on above issue, i am trying to build mobile app

Hello , i have the same error

Hi Axelor team,

Is it possible to help from Axelor team to fix this issue.

Thanks & Regards
Ayoob A.

1 J'aime

Thanks , i m surprise that no more person are interested by this source code

I am interested, but currently do not have enough knowledge to comment on this topic.

Hello no more information ? Axelor team ?

Hello , i have resolve the first issue , with this command
« build »: « lerna run prepublish --scope @axelor/* && lerna bootstrap »

change '@axelor/’ to @axelor/
but a new problem to run enable to find lib\Tapable.js
I try to solve …
Regards

Hi Durtuat,

Thank you for your update, after chaging the lerna build command, i am able to build successfully. Please find the below screenshot which i have made change in packege.json file.

Hello, yes it s this change i made . I have other errors when i run project , i trybto solve . Regards

Hi Durtuat,
For me its working fine and able to complete build successfully.

Build yes but not run

I have do a nex instal with correct line on beginning , and it s work on browser , but il ca not create APK
Regards