Hello, how can I add a new report to axelor using BIRT and view the same report in axelor in the browser

Hello, how can I add a new report to axelor using BIRT and view the same report in axelor in the browser after building the project


You may find some of your questions in the following topic:


how can I see the report I created in the axelor program in the browser

If the name of the .rptdesign is the same as that of the original .rptdesign, the menu entry or the button to simulate it, is the same, otherwise you must create an additional menu entry or access button, if the .rptdesign name is different.

Copy the modified XML file from .rptdesign, managed in the Eclipse workspace, into the directory of the server that hosts the Axelor application (This path must be specified in the application.properties file via the reports.design.dir property – exemple reports.design.dir = {user.home}/data/reports)

Axelor will now run the modified report template, without any other operation (no relaunching the application, etc.) : the simple copy in the directory of the server makes it possible to take into account the new report. The modification is done in live.
Hereinafter, the modified part of the report.

If these explanations are not enough, you will have to detail your actions in more detail: which .rpdesign is concerned, how did you simulate it before making your modifications, etc.

i created NEW report in Sale module with BIRT and gave the same name SaleOrder.rptdesign and locate it in reports.design.dir = {user.home}/data/reports ) and run the app. so it is running on port:8080, everything is good but when i want to see the reports of Sale module via the browser, it gives me ERROR 4928 — [nio-8080-exec-3] o.e.b.r.engine.api.impl.ReportEngine : invalid design file SaleOrder.rptdesign!? can it be because of the version of Birt or version of Axelor?
i compared the .rptdesign files which i created and one is already exists, so one is exists used Birt version 4.9 and i created with 4.13 version, axelor version is 7.0.3

thank you very mauch

problem solved by changing the version of BIRT

Hello Aza!
I had the same error what version of Birt did you use please

could you pls try this