How to compile ADK WIP branch and set AXELOR_HOME?

Hi all,

Gradke 4.4.1,Tomcat7, Postgres 9.5; JDK 1.8 on CentOS installed.
Goal…install ABS WIP

I try to compile like for previous version the ADK first
So I do the following

git clone
cd axelor/axelor-development-kit

now I use the WIP branch…so I execute the next statement…
git checkout -b wip remotes/origin/wip

but in the previous install with master branch we needed to run
./gradlew installDist

installDist is not present in the WIP branch…
so I tried

Is that correct ? Resut was green, but I cannot find the directory I need to export to set AXELOR_HOME like in the previous version…
export AXELOR_HOME=/path/to/axelor-development-kit/build/install/axelor-development-kit
$ export PATH=$AXELOR_HOME/bin:$PATH

Do you have any idea ?
And for next step I need to compile ABS

How to change the .gitmodules to take the WIP branch of the ABS ?
Previously, it was
vi .gitmodules
[submodule “modules/abs”]
path = modules/abs
url =
[submodule “modules/axelor-process-studio”]
path = modules/axelor-process-studio
url =

If you have any idea…you’re welcome, thanks

no need to clone adk, it’s fetched from dependencies in abs-webapp (moreover it seems that development is done in a closed fashion and regularly pushed to github so it would most probably fail if you used the git version).

git clone [abs-webapp]
cd abs-webapp
git checkout wip
[edit submodule to use https]
git submodule init
git submodule update
./gradlew war

War is in build/libs


1 « J'aime »

many thanks @beuss already…
now when I run ./gradlew war

I have an error
FAILURE: Build failed with an exception.

  • Where:
    Build file ‘/home/axelor/abs-webapp/modules/abs/axelor-account/build.gradle’ line: 1

  • What went wrong:
    A problem occurred evaluating project ‘:modules:axelor-account’.

Plugin with id ‘axelor-module’ not found.

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at

did you get this one as well ?

ok it seems if we add

sudo git submodule foreach git checkout wip
sudo git submodule foreach git pull origin wip

like in the old version before
./gradlew war

it’s compiling !!!

Yes sorry, forgot to tell you to checkout wip for modules/abs too…
Glad you solved it quicker than I could answer :slight_smile:

1 « J'aime »


Now I will try to run it

Many thanks @beuss, one day, if I can, I will offer you a drink :slight_smile:


de mon coté, j’ai cette erreur que j’arrive pas résoudre,
j’ai surement du faire une mauvaise manip !

FAILURE: Build failed with an exception.

  • Where:
    Script ‘/Applications/MAMP/htdocs/axelor/abs-webapp/gradle/adk.gradle’ line: 15

  • What went wrong:
    A problem occurred evaluating script.

AXELOR_HOME is not set properly

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.


Je te rejoins Beuss sur le wiki car c’est vrai que pour un novice, c’est pas très simple à mettre en place ! :wink:


Si tu as cette erreur c’est que tu es sur la branche 4 (ou 4.1), il faut suivre le guide de l’ADK dans ce cas :

I made a little error this morning and needed some time to find where…I missed a /

Finally I got it !! Now the story really begins
Special thanks to @Axelor and @beuss

So it’s running on CentOS 741 with 4Go Tomcat7 JDK1.8


Spent the day (like others I see) trying to get this going and I got all the way through and produced the .war

However, I can’t seem to get it to run. What am I missing? @k26? You got it to run, right? Is there a last step trick I am missing?

hi @censon yes it’s running…for my config on CentOS…but it’s difficult to help you, as I don’t know which system you use, which things you did to install, where you are now, what is blocking. But I think if you were able to generate the .war, then, you are really not far away !
Check your connection with postgres, check that the postgres user is able to connect to the database, check the pg_hba.conf file …sometimes it could be a little mismatch…in the password, url…and check the file…
check the .war is in your tomcat directory… for me /opt/tomcat/webapps…
check the postgresql.conf file for parameters listen_addresses and port…

you can use that php to check the connection with your postgres
sudo yum install -y php;
sudo yum install php-pgsql -y;

then create a test.php
// Connecting, selecting database
$dbconn = pg_connect(“ dbname=yourDB user=yourUser password=yourPassword”)
or die('Could not connect: ’ . pg_last_error());

// Closing connection
then execute with php test.php
if it’s not running, then, your user has maybe a wrong password in postgres

Otherwise you need to provide some more details to get more precise tips…

psql -h [configuredhost] [configuredUser] [configuredDb] is far more convenient :slight_smile:

@k26 thanks for that. I have the war generated and suspect that is must be the postgres connection. Will work on it over the weekend. Your advice is appreciated.

And this error :

Caused by: com.zaxxer.hikari.pool.HikariPool$PoolInitializationException: Failed to initialize pool: org.postgresql.jdbc3.Jdbc3Connection.isValid(I)Z
at com.zaxxer.hikari.pool.HikariPool.checkFailFast(
at com.zaxxer.hikari.pool.HikariPool.(
at com.zaxxer.hikari.HikariDataSource.(
at org.hibernate.hikaricp.internal.HikariCPConnectionProvider.configure(
… 37 common frames omitted
Caused by: java.lang.AbstractMethodError: org.postgresql.jdbc3.Jdbc3Connection.isValid(I)Z
at com.zaxxer.hikari.pool.PoolBase.checkDriverSupport(
at com.zaxxer.hikari.pool.PoolBase.setupConnection(
at com.zaxxer.hikari.pool.PoolBase.newConnection(
at com.zaxxer.hikari.pool.HikariPool.checkFailFast(
… 40 common frames omitted
2018-02-09 13:41:23.189 ERROR 10624 — [ost-startStop-1] o.apache.catalina.core.StandardContext : One or more Filters failed to start. Full details will be found in the appropriate container log file
2018-02-09 13:41:23.189 ERROR 10624 — [ost-startStop-1] o.apache.catalina.core.StandardContext : Context [/axelor-erp] startup failed due to previous errors

Running at http://localhost:8080/axelor-erp
<============-> 99% EXECUTING

I can’t understand where it comes from.
Yet my connection to postgres is good !