How to enable Hotswap


I’m trying to run my app with Hotswap but have some issues.

I’m running AOP 6.1 - OpenJDK11 - Windows 11 - with VS Code and « Debugger for Java » plugin.

I created a custom module for testing.

I created a launch.json file

    "version": "0.2.0",
    "configurations": [
            "type": "java",
            "name": "Debug (Attach)",
            "request": "attach",
            "hostName": "localhost",
            "port": 5005

And I linked it to my workspace project. I took a few seconds of loading to cover the project i guess…

Then i did :
$ ./gradlew --no-daemon run --debug-jvm

I waited for the line :
Listening for transport dt_socket at address: 5005

Clicked the VS Code debug icon and click " Debug (Attach)"

Here’s the " Java: Java Build Status (axelor-AOP-6-1) " terminal logs

I did a change on my XML view is VS Code after launching the app, and the java build terminal created a new build.

Heading to the app , i clicked " Reimport all the views " and it didn’t worked.

It works when i stop the app and relaunch with
$ ./gradlew --no-daemon run then Reimport the views again and now it works I don’t need to build the app, but I still need to relaunch the app for updating the XML views

Any help on this ? I didn’t installed Hotswap agent neither DCEVM the 6.1 Axelor doc don’t specify but the 5.4 Doc does. So i did this way.