How to install Axelor from WAR file in Windows 10?

Hi Everyone,
I want to use Axelor Permanently that’s why i wanted to install it into my PC.

Please guide me to install Axelor from WAR file.

I have some problems, too, installing axelor on windows 10. Is there a step by step guide, including the prerequsites, for the insallation procedure?

1] Here is the link: Installation

2] If you just want war file then check here and download the latest release : Releases


Thanks akbar for the link.
I am not a Techy so this guid is to rough for me and it referes to the devopment environment.
I just want to use it as a production system.

I Installed Postgres, Tomcat 8.5, so far every thing is ok. And then? How should I proceed If I have no clou what Tomcat is and does.

Can you or anybody else give a moe detailed guidance?

Hi @acryl-tec, try axelor all-in-one bundle for windows instead.

Thanks for the tip, but the webapplication does not start after axelor has finished setup.

I tried to install from war archive, but there, too, the web aplication does not start.
Error message:

HTTP Status 404 – nicht gefunden

Type Status Report

Message /axelor

Beschreibung The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Apache Tomcat/8.5.49

What kind of privileges do I need to change so the application starts?

I loved the demo and the things you can do with axelor, but if the install process is a big pain (and documentation for trouble shooting is where?) axelor will not gain many useres.

PostgreSQL 12.1, compiled by Visual C++ build 1914, 64-bit is the Database I use.

Uninstall or stop your existing postgresql and/or tomcat server to prevent port clashing or change ports from axelor launcher ui before starting the app.

Thanks for the quick answer.
Where do I change Ports?
What is axelor launcher ui?
Please think of me as a 4 year old child that has no clou about the backend stuff and try to axplain it accordingly, that means idiot-proof.

Are you using all-on-one bundle? See the first screenshot here, you can change “Web Port” and “Database Port”.

The all-in-one bundle provides easiest way to test axelor but still it’s a complex software, some will need some technical knowlege as in many cases the bundle may not work. For example, if you have any other app running on your computer using same ports.

I have used same all in one bundle for windows. after installation got complete i clicked on open in browser and it worked well. i tried few things around and then clicked on hide button of installer. then i shut down my PC. on next day when i try to open same localhost:8080 it was not working. is there any solution for it?