Impossibilité de transférer une facture en compta et d'en saisir le paiement

Bon alors :


J’ai saisi une factures fournisseur, à partir d’un PO. Tout va bien. Maintenant, j’aimerais saisir le paiement et cette facture ne remonte pas, lorsque je clique sur « Rechercher les pièces à régler ».
Et si je confirme le paiement :
WARNING! Aucune ligne à payer
Encore merci pour votre aide. Et hormis ces « petits » soucis, j’adore votre solution et je la préconise!
Fanny

Bonjour,

Votre facture semble être au statut “Validé”. Vous devez la ventiler (bouton “Ventiler” sur la facture) afin qu’elle puisse être traitée comptablement et que vous puissiez enregistrer un paiement.

Certains de nos clients utilisent cette étape de ventilation dans leurs processus, mais elle ne fait pas toujours sens pour toutes les entreprises. Dans le prochaine version V5 nous avons prévu une option permettant de désactiver cette étape de ventilation.

Cordialement

Parfait! J’ai compris! Ça fonctionne maintenant.
Merci encore 1 000 fois (au moins!)

bonjour,
j’ai créé une facture et je l’ai ventilé, mais au moment du saisie du paiement je ne trouve aucune facture en cliquant sur “Rechercher les pièces à régler”, veuillez m’aider si vous avez la solution.
Merci d’avance.

Je rencontre le même problème (en V5). Ma facture d’achat est bien à l’état “ventilée”, elle est arrivée à échéance, mais elle n’apparaît pas en proposition de paiement. Je ne parviens pas non plus à l’ajouter manuellement. Enfin passer le SQL en debug ne m’a pas aidé non plus sur les critères de recherche, la logique des requêtes générées restant pour l’instant difficile à interpréter pour moi…

Bref, tout indice serait le bienvenu sur les critères qui permettent de rattacher une facture à un paiement… merci d’avance

Bonjour,

Je viens de tester cela fonctionne. Normalement depuis le menu Assistant Paiements (module comptabilité), vous cliquez depuis la vue liste sur + pour ouvrir une nouvelle saisie paiement.

Vous devez en premier choisir votre type de paiement, qui est « Achat fournisseur » si c’est une facture d’achat. Ensuite dans le panel « Payeur » vous sélectionnez votre tiers (le fournisseur qui doit être payé), et le mode de paiement est rempli automatiquement si vous avez indiqué sur la fiche du fournisseur un mode de paiement sortant (onglet Facturation/Paiement).

Ensuite vous devez cliquer sur le bouton « Rechercher les pièces à régler » et la ou les factures doivent apparaître dans « Liste des factures/échéanciers avec restant à payer ».

Vous rentrez ensuite votre montant dans « Montant payé » puis sélectionnez votre ligne de facture et devez cliquer sur « Charger les lignes sélectionnées ».
Vous pouvez alors confirmer le paiement.

Sinon vous pouvez directement depuis une facture ventilée enregistrer un paiement en cliquant sur le bouton correspondant.

1 « J'aime »

Bonjour et merci de votre réponse,

C’est cette partie là qui ne fonctionne pas dans mon cas. Et je ne parviens pas à trouver les critères pris en compte pour que la facture soit proposée au paiement : elle est bien échue, sur le bon tiers et le bon mode réglement…
Comment connaître les critères de sélection du bouton “Rechercher les pièces à règler” ? Le passge en debug de org.hibernate.SQL est bien trop verbeux, et je n’ai pas encore trouver mon chemin dans les requêtes générées…

Merci d’avance

Bonjour,

La recherche se fait dans la méthode com.axelor.apps.account.service.payment.paymentvoucher.PaymentVoucherLoadService.getMoveLines(PaymentVoucher)il faut que ce soit le même tiers, qu’il reste quelque chose à payer, que la facture soit ventilée et appartienne à la bonne société.
Il faudrait, je pense une capture de la facture concernée pour pouvoir avancer

Cordialement,

Facture, échue

Si je clique sur « Enregister paiement », j’arrive sur l’écran de paiement / rapprochement de facture :

Mais quand je clique sur rechercher les pièces à régler, rien. J’ai aussi essayé d’ajouter manuellement la facture en ajoutant une « Liste des factures.échéanciers avec un restant à payer », mais sans succès (en fait je crée une liste, mais je ne vois pas comment ajouter un numéro de facture dedans)…

Une idée ?

J’ai fini par récupérer le sql (merci @beuss), qui donne à peu près ça :

select *
FROM   account_move_line moveline0_
       LEFT OUTER JOIN base_partner partner1_
                    ON moveline0_.partner = partner1_.id
       LEFT OUTER JOIN account_account account2_
                    ON moveline0_.account = account2_.id
       LEFT OUTER JOIN account_move move3_
                    ON moveline0_.move = move3_.id
       LEFT OUTER JOIN base_company company4_
                    ON move3_.company = company4_.id
WHERE  partner1_.id = 6
       --AND account2_.use_for_partner_balance = 't' --nok
       --AND moveline0_.amount_remaining > 0 --nok
       /*AND move3_.status_select = ?*/
       AND move3_.ignore_in_debt_recovery_ok = 'f' --ok
       /*AND company4_.id = ?*/
       AND moveline0_.credit > 0  --ok 

Les deux critères qui semblent interdire à ma facture d’être rattachée au paiement sont :

account2_.use_for_partner_balance = ‘t’
et
moveline0_.amount_remaining > 0

Si je comprends bien, mon 401 n’est pas flagué comme compte auxiliaire, et le reste à payer est à 0 (peut-être pour la même raison ?).
J’ai sans doute un problème de paramétrage initial. Quelqu’un a une idée ?
Merci d’avance
Franck

Il semble que dans les comptes, l’option “Utiliser pour le solde des tiers” doive être cochée. Cependant, je ne comprends pas pourquoi ce n’est pas le cas par défaut du 401, du 411, etc… Ce qui me fait penser que je rate peut-être autre chose…

Bonjour,

Vous avez importé le plan comptable depuis l’application ?

Oui, je crois : j’ai utilisé la fonctionnalité « Configurations comptables / Generate account configurations » de l’écran de configuration de l’application Compta (en V5).

Oui et ensuite, dans les détails de la configuration, avez-vous cliqué sur “Importer un plan comptable” après avoir sélectionné French Chart of accounts?

oui, c’est ça… je vais recommencer sur un autre environnement et observer ce point particulier de la configuration des comptes auxiliaires.

J’ai créé une seconde société (Test) et répété la procédure d’import du plan comptable français. Le résultat est le même, les comptes ne sont jamais flagués comme auxilaires…

select * from account_account where use_for_partner_balance = 'Y'

confirme qu’aucun compte ne porte cet attribut (sauf un que j’ai modifié manuellement hier pour faire aboutir mon test de paiement).

Un exemple :

Dans le dépôt git, le fichier axelor-business-suite/axelor-account/src/main/resources/l10n/l10n_fr/PCG/account_account.csv ne contient d’ailleurs pas cette colonne… C’est peut-être un ajout de la V5, et le fichier de données n’a pas suivi ??

Bonjour,

J’ai répondu sur l’autre thread, effectivement le PCG ne contient pas l’attribut, en revanche, le CSV de démo le contient (https://github.com/axelor/axelor-business-suite/blob/wip/axelor-account/src/main/resources/l10n/l10n_fr/PCG/account_account.csv#L395)
@admin : serait-il possible que les équipes d’axelor fassent une passe sur le fichier ?

Cordialement,