Install Axelor using Docker


I’m trying to install Axelor using Docker by following the doc: Docker :: Axelor Documentation, but it seems to be out of date.

The only official docker image that seems to be updated are axelor/aos-preview-app and axelor/app-builder. The first one is not expected to be used in production, and I do not know how to build a proper docker from the second one. Sadly, the source code is missing.

The krabugrupp/myaxelor seems to be quite used, but since the source code is nowhere to be found, I can not be confident enough to use it.

Is the Dockerfile in still relevant ? Do you have any guidelines to build a proper Dockerfile for Axelor?

Thank you,


Our docker is an all-in-one image, including all the necessary technologies to deploy the application. Although the last update was few years ago the docker , we use variable to get the latest version of the application as you can see there:

We will soon provide videos to explain all the ways to install our app.


1 « J'aime »

see below the link it might be helpful

@pco-axelor Thanks for the answer, I will probably use something close to the aoi-builder since I want to create my module for Axelor. I have another question regarding the aoi-base docker, do you think I can replace Tomcat and Postgresql with a newer version? I did not see an option, so I guess I’ll have to modify it and build it locally but I do not know if the whole application will still run properly.

@siddique Thanks, this will help me as I was planning to do something pretty close to the workflow you present.

Thank you both for the quick response regarding confirmation that the dockers are indeed usable even though they are quite old.

I give it try things work, just need to add npm too

we can go with tomcat 9 and postgres 12 at least

postgres 13 14 needs updated driver which I tried but no luck

@siddique I also tried to use postgres 13/14 but it did not work. So I modified the Dockerfile in the aio-base to use postgres12 and add the necessary dependency.

I have another problem with Docker. How to use the volumes correctly ?

I wanted to create a volume from /var/lib/postgresql on my host to /var/lib/postgresql on my docker. But I have a user permission problem. If I create a volume from somewhere else in the file system, the docker will not have a permission problem (because it will create the folder itself). But if I delete the container and rebuild it, the permission will be wrong since the UID/GID of the docker that created the folder is not the same as the current container. And the problem is the same with the volume for tomcat.

Is there an appropriate way to do this? Even if multiple dockers are using the same volume?

Last but not least, the overwrite, but I do not understand why. How can I use my own without removing this weird behavior?

Thank you,