Linux WAR deployment problem

Hello. Following the “Install from WAR” guide, have installed the necessary pre-requisites, can start the tomcat server, and localhost:8080 brings up the tomcat home page.

Have made the necessary changes to axelor-erp-5.4.0/WEB-INF/classes/application properties, and copied the whole directory to /ylem/opt/tomcat/webapps. However, when I run the command ‘su -s /bin/bash -c “/ylem/opt/tomcat/bin/ run” tomcat’, although I can still get to the tomcat home page, when I try to load localhost:8080/axelor-erp-5.4.0, I get an http 404 status error.

The console output from the startup command shows a lot of INFO messages, which I guess is OK, but then comes up with the following output

23-Sep-2020 10:02:22.329 WARNING [localhost-startStop-1] org.apache.tomcat.util.descriptor.web.WebXml.setVersion Unknown version string [4.0]. Default version will be used.
23-Sep-2020 10:02:33.498 INFO [localhost-startStop-1] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
23-Sep-2020 10:02:47.520 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.startInternal One or more Filters failed to start. Full details will be found in the appropriate container log file
23-Sep-2020 10:02:47.520 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.startInternal Context [/axelor-erp-5.4.0] startup failed due to previous errors
23-Sep-2020 10:02:47.614 WARNING [localhost-startStop-1] org.apache.catalina.loader.WebappClassLoaderBase.clearReferencesJdbc The web application [axelor-erp-5.4.0] registered the JDBC driver [org.postgresql.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.

I also see another message (this is the only one that seems to be tagged as “ERROR”), which is complaining that the database “axelor” does not exist. Does this mean that I should previously have created the “axelor” database? There is no instruction to do so in the installation instructions, but as the instructions for creating the “axelor” database user do not give it superuser power, then surely it is necessary (as the postgres or other privileged user) to create the database before deploying the WAR?

Solved - yes you DO have to create an empty “axelor” database first. Then it is all OK

welcome to axelor, yes we need to create empty database as the connection string use that