Setup ABS in eclipse


I would like to know if i can setup ‘Axelor Business Suite’ in eclipse. I tried the same way we setup ‘axelor-demo’ but unable to succeed. I checked out ‘abs-webapp’, updated repository (including submodules) to 4.1, generated eclipse using gradlew command and imported to eclipse. There were no errors but i am unable to access the context on ‘/abs-webapp’ path in tomcat. Also no info in logs like creating tables etc.

Any help pls…

It is because of the web.xml and tld is mIssing in your webapp of tomcat. I dont know why it is happening and dont know to fix it permanently. But you can copy it from abs/build/webapp folder, and restart the server. Hope someone can provide a permanent solution.

Hi !! i have the same error as krishroopkk, and i tried what you proposed, but it didn’t work for me.

Once tomcat loaded, check the webinf directory, the files will be deleted whenever you save something in eclipse. Copy again and restart the server. Also change timeout in config. I made it work somehow, but still waiting for some expert advise from the forum.

i’m working on the same subject, i’ve changed the web.xml of tomcat server by the web.xml of the current project .but it doesn’t work and i don’t found any file tld into tomcat folder

TO clear this, what i did is copy webxml, axelortld from eclipse-Workspace/abs-webapp/build/webapp/WEB-INF to Tomcat-Deploy/abs-webapp/WEB-INF and restart server.

Update: right click on abs-webapp, take properties and add build/webapp to deployment

Works, thanks for your help.