Struggling to Install Axelor

Hi All, I have been trying for days to resolve but no luck…pls help!

I have followed the installation instructions for WAR windows installation.

installed - JDK, Tomcat & Postgres - then WAR file. Copied WAR into Tomcat->Webapps.

Corrected the application file as per below

Database settings


db.default.driver = org.postgresql.Driver
db.default.ddl = update
db.default.url = jdbc:postgresql://localhost:5432/axelor
db.default.user = axelor
db.default.password = axelor

Created Database -> axelor
Created Login User -> axelor with password axelor

But no luck when i enter url localhost:8080/axelor…all I see is as follows

HTTP Status 404 – Not Found

Type Status Report
Message The requested resource [/axelor] is not available
Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Hello! @miroslav
If you deploy your war as ROOT.war
You can access to the application using following URL http://localhost:8080/

otherwise, you need to deploy your war as axelor.war to use http://localhost:8080/axelor
Hope you can solve it.

1 « J'aime »

Hi there still no luck.

The only difference in error message, I dont now see
Message The requested resource [/ axelor] is not available

Instead I have following error message

Type Status Report

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

To further explain, I installed all 3 pre-requisite apps with no special scripting etc.

Am I suppose to do anything special with TomCat or Postgresql?

The war file, i simply extracted and changed the properties of then copied over to tomcat\webapps…

Have i missed something ?

Is the war deployed on tomcat ?

how did you deployed the file?
Are you using Linux or windows? About linux how did you configured tomcat and user/permission?

What name did u used to deploy the WAR?

Hi All,

I am using Win10. The WAR file I extracted first, then changed I then copied the entire WAR Extracted version to Tomcat\webapps. Did I have to zip WAR file again and then drop into Tomcat/webapps?

Hi there,

I had the same issue, in my case, there was a problem regarding the database authentication (but I don’t know, why it happened). Anyway, deleting the postgresql folder in var/data solved my problem…good luck :slight_smile:

not , war can be copied , and tomcat started . you can have a repository create on tomcat , with the name of the war .

No luck…I started install process all again (after removing everything)…

Still can’t access…does any one have a dummy step by step process…cause the one on the installation guides on website for WAR install hasnt worked for me?

is it deplyed or not ?

pls clarify what you mean by deploy? I have copied extracted WAR file to tomcat\webapps…

What is involved to deploy> the steps pls?

Sorry for my ignorance but I have been trying many days

With the word « deploy » the physical copy of the WAR inside tomcat/webapps
For the test copy that war with this name « ROOT.war »

When tomcat start , it deploy web app from war file to repository . Verify if this repository is created