Studio CSS bug in docker version (Axelor 5.1.x and 5.2.x)

Hi, there is a mistake with Docker install of Axelor 5.1.x with the studio.
CSS is not loaded correctly so the studio is unusable


Install from source seems working fine.
Testing the load of two different instances (Docker and From source) indicate that main.css is not loaded the same way…
Any idea of the problem ?
Thanks
Regards

Ok we have found a workaround. In fact the problem is near the main.css located in /var/lib/tomcat/webapps/ROOT/studio/custom-model/static/css in the container.
We don’t know why but Tomcat always answer a main.css about 5KB even if the main.css located in web root is about 300KB (the content is completly different). You can delete this file, Tomcat still give an incorrect version and we don’t know where this file is located on the container.

we had tried different .WAR versions (5.1.8, 5.1.10) and create our WAR file from source. Each time it’s the same result. It seems the issue is coming from Tomcat server that always give incorrect main.css

The workaround :

  1. Enter in the container with “docker exec -it {container-name} bash”
  2. edit /var/lib/tomcat/webapps/ROOT/studio/custom-model/index.html
  3. Locate the main.css call and rename it to mainstudio.css for example
  4. rename /var/lib/tomcat/webapps/ROOT/studio/custom-model/static/css/main.css to mainstudio.css
  5. Purge all cached page from your web browser and it should work

This is a workaround so it may be important that Axelor create a new docker build to fix it definitively.

Hope this workaround helps somebody !

1 Like

thanks that made my day! :smiley: