Translate language to Chinese

Hi,
May i know how can i translate the axelor to chinese.

I have added chinese language at Application Config>General Data > Language.
and have added in some chinese text in Administration> View Management > All translations.

But i unable to select the chinese language at User Preferences Page.

Any suggestion?

Thanks

Hello
You need to add a new entry in your select.xml file for that form.

Thanks for your reply.
May i know where can i find select.xml?
I’m currently install through https://github.com/axelor/open-suite-webapp
Thanks

Hello @Mcwei

You can change the select values here under your modules directory
axelor-base/src/main/resources/views/Selects.xml

Sorry, I’m new in axelor. Do you mean that i need to setup
https://github.com/axelor/axelor-open-suite first? and modify from the code and regenerate the projects?
I have try to build axelor-open-suite, but it throw ./gradlew: No such file or directory error.
Any guidelines to setup these?
Your help is very appreciated.

Thanks

I think when you setup using open-suite-webapp he should install also all modules from open-suite.
Anyway yes you must change the XML.
Browse and look what folder your application from open-suite-webapp creates?

I have manage to add the new language.
But the next problem i face is the new language will not appear if i replace the existing project. It need to be fresh database which is empty.

Is there any idea to update the project without need to be fresh empty database?

Thanks

1 J'aime

Hello @Mcwei
Should be enough if you manage your translations table.
Adding Chinese translations there, as well as you can add new CSV files for the Chinese language

Yes. It will be fine if it is new project, builded war file(with chinese language in selects.xml) will reflected and i can choose chinese at user preferences.
But if existing project with some data in database, i have try by update/resetup using newly builded war file(with chinese language in selects.xml) , user preferences page still do not have chinese language for me to choose.

Thanks

1 J'aime

There are 2 places with user preferences for languages.
So You have to change in 2 different forms.
If your « regeneration » is set on update you should not have any issue with existing projects.

Thanks for your reply.

May i know where can i set the « regeneration »?
Thanks alot for your help

Thanks

Application properties

Database settings

~~~~~

db.default.driver = org.postgresql.Driver
db.default.ddl = update <- This « regeneration »

If you use a CSV file for your language you will not have any issue with existing Axelor applications.

I’m getting error as below after change db.default.ddl = regeneration

1 J'aime

Must be update as is db.default.ddl = update
I meant « regeneration » it regenreate updateting without deleting your data.

Thanks for reply.
Maybe i try to make it clear on my issue.
I have install axelor released .war (Without Chinese Language) in my server and there is some data(projects/users/…) and configuration inside.
And now i would like to add Chinese language into project.

Once complete modification, i have move the axelor-open-suite into open-suite-webapp > modules and generate .war file.

I have open up a new port for this .war file(with chinese language) and created new database. I have manage to to get chinese language selection at user preferences page.


And i have checked the All Translation menu, there is chinese « cn » and translation that i have fill in in message_cn.csv.

It is working as per expected in fresh/new project.

However, i have move the same .war(with chinese language) into existing project and replace the previous project folder.

After i restart the tomcat, i notice that the changes that i have make (message_cn.csv and add chinese language into selects.xml) does not reflect to the existing project.

  • user preferences page still does not have chinese language selection
  • All translation also do not have « cn ».

Is there anyway i can do so that the changes will be reflected to the existing project which database have data inside?

So far as i know when i restart the tomcat, Application properties will regenerate and db.default.ddl = update is already set.

Thanks for your help and support
Very appreciate this.

Thanks

Have you tried to click the Rocket button it should export and use your new language.

Hi,
I’m getting error as below after click rocket button.

Will it be able to get the language selection at preferences page if i successful upload message_cn.csv?

I thought it will follow the changes at selects.xml?

Thanks

There is an illegal character inside that csv file.
if you don’t use french you can delete it.
I removed all files I don’t use.

I have try by deleting the all .csv except english and chinese in axelor-base. But same error still appear.
From the error message, it showing that it is from axelor-core.jar but i do not see axelor-core in axelor-open-suite modules.

thanks

Very weird
Did you change axelor-core ?