Unable to compile class for JSP

Hi there,

I am trying to run the axelor erp. but after the build, when I run ./gradlew run I get this error `org.apache.jasper.JasperException: Unable to compile class for JSP


this only happens with the newest version on github

The issue was caused by a breaking change in tomcat and we upgraded to that version. The issue is fixed in this commit https://github.com/axelor/axelor-open-platform/commit/b8b5ec9008a9f804b0922cb240540a6f79caae91. So latest sources should work. Try the latest release or master branch and report back.

Hi there,
I try your new method for run application with intellij : https://docs.axelor.com/adk/5.2/getting-started/idea.html and i have the same problem.

First, I run like say your documentation and my tomcat don’t run, so i add classpath "com.axelor:axelor-tomcat:5.3.+" in my build.gradle but i have the problem of JSP.

And more, it’s normal application is too long for start message “Configuring database” ? about 4-5 minute for start that.

Hi @AVR-David, the app startup is slow on windows (we don’t know why yet, we haven’t checked in details). Also on Linux, it may take some time when you run the app first time.