Upgrade from AOS v7.2.6 to v8.0.4 breaks login

I have a script so that I can quickly switch release versions. I was testing upgrading from v7.2.6 to 8.0.4, and the upgrade deployed to my tomcat server, however I was unable to login.
re-deploying with v7.2.11 worked fine. has something changed in 8.x versions that requires changing the database so I can login with one of my user accounts?

I can’t tell right now what may be wrong, but please provide some more information in order to help someone to help you :

What is the procedure of your script ? (tell us if it starts/stops a db engine, data backup/processing, application server tuning… even the langage of the script)
Where do your 7.2.6, 8.0.4 and 7.2.11 come from ? (community self build from sources from github using tags, or official prebuilt downloaded ".war"s, or whatever)
Which version of Tomcat ? What config/parameters ?
Which JRE/JDK ? OS ?
Can you log in as admin/admin in the v8 before attempting to use any custom data ?
What log level do you use ? What error messages do you see in the logs ?
« About » / « system info » are useful as the precise version you have provided.

The logs should give clues.

I should have been a bit clearer, my script is simply a bash script where I can set the tomcat version, axelor version, and database credentials(allowing me to choose if I want the .war deployed with an existing database, or a new one)
I was testing how the new 8.0.4 release would work with an existing 7.2.x database, and like I said, it deployed, but I couldn’t login. I read the migration docs on Axelor Open Platform 6 to 7, and saw the bit about plain user passwords are no longer hashed upon startup. The users in my 7.2 database already had a hashed password stored. just for kicks I tried using the example hash in the migration document, and still could not login when using the database with the 8.0.4 release, but I could login when I deployed 7.2.11, and the hashed password updated from the migration guide worked. I changed it after login.

I upgraded to tomcat 9.0.87, and tried axelor 8.0.4 first, then axelor 7.2.11
(from official releases at github.com/axelor/axelor-opensuite/releases/download)
since I’m testing with a pre-existing database, my script does not reload postgres, however it does restart tomcat for the .war deployment.
I’m running on bookworm/sid,
I generally use catalina.out to troubleshoot if I need to. I’ll do that next if we have to go that far. Since the migration guide doesn’t mention having to do anything to login, I may have found a bug of some kind. I don’t have a lot of data in our cms yet, so I could go ahead and start v8.0.4 with a new database, and migrate the users over.
I haven’t started to do custom builds yet, but that’s next, we plan to develop our own functionality and contribute back to the community.
Thanks everyone

I may have missed something, since I’m new to axelor. Is there a database update file that needs to be applied for each version upgrade? Since axelor creates everything it needs for an empty database, I had assumed it would apply any changes it needed when detecting a database of a previous version.


Some posts on the subject concerned which may possibly help you


OK, I’ve read through these, except the french ones.
I’m a linux engineer, who’s worked previously on javaEE projects, and I’ve done tomcat application hosting, but the Hibernate JPA ORM is new to me. It was recommended to take a scheme diff, and apply that. Is there a scheme diff file that is included in each release, as you would expect with a project, or is it assumed that an admin will install each release on a blank database, and need to take a schema diff for each version? What will the JPA ORM take care of, and when is it necessary to do a schema diff? I’m only on a testing database currently, but we expect our crm to grow by hundreds of users in a production environment, and I’m just trying to get a feel for the axelor way of doing things. Documentation is pretty good, but there is a lack of certain things, and detail sometimes. I will be contributing to this community, and thank everyone who’s responded. Much appreciated!

Hey Barry,

I did successfully upgrade to 8.0.4 from 7.2.7, definitely took some effort. My understanding is that major release versions tend to have big schema changes and small release versions apparently aren’t even worth worrying about it seems.

The pgadmin tool definitely helped in applying the differences. It’s not perfect but with some trouble shooting skills it’s manageable. They offer a maintenance contract supposedly and would provide you the migration scripts for each version. If not, you might need to get the commerical pro version that offers the updates.

They don’t supply a scheme diff file for each version from what I know. I just spun a VM up and installed the latest version. Definitely tedious but it’s the community edition so. You could probably minimize downtime with a script to install axelor erp into the VM. That’s what I plan on doing at least. Not sure on the reason for making a schema diff script unless you have more than one instance.

Hopefully this helps you, I’m also learning it as well

Thanks, and good to know.
btw, with tomcat you can deploy separate apps in the webapps folder, so that’s what I would do on a tomcat testing server, with the different releases. on our production one, I move to the ROOT folder.
just letting you know there is no need to re-deploy a vm every time you want to deploy axelor, and test different versions on different databases.

Oh geez, I had a feeling that was more than likely possible. But since I’m not too familiar with tomcat, I didn’t venture on that yet. So you’d have like webapps/Test and webapps/ROOT? Wouldn’t tomcat launch both webapps at the same time? I’d have to define the application URL in the config properties so they both have different ports no?

tomcat launches the webapps as a foldername, so name one axelorv8.0.4, and axelorv7.2.11, etc…
your axelor config sets what database the app uses, so as long as each is using a different database, then they can run simultaneously. for instance, while testing, I launched 2 of the same version, one with demo data loaded so I could compare the databases, and figure things out.
the ROOT folder launches at the root url of the domain you set up tomcat on.
I had used the ROOT as the axelor version I planned to use, and axelordemo as the demo data version.
I accessed it at http://localhost:8080/ and http://localhost:8080/axelordemo
lots of documentation on tomcat and urls, ports, etc…

Oh cool. That makes more sense to me. Seems like I’ll have to define a context path for each folder from doing a little research on it. I’ll try this out since it’s way more convenient. Thanks for the help!